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Chapter 1

Software Installation and Hardware Setting

1.1 Installing the Win-GRAF Workbench
Before installing the Win-GRAF Workbench, check the installation environment on your PC.
System requirements:
 O.S.: Windows XP, Windows Vista, Windows 7, Windows 8 (32-bits or 64 bits)
 Microsoft .Net Framework 3.5 (Download it on the Microsoft web site:
http://www.microsoft.com/zh-tw/download/details.aspx?id=22)
 RAM: 1 GB minimum (Recommended: 2 GB or more)
 Available hard-disk space: 200 MB minimum
Installation Steps:
1. Double-click the “Win-GRAF-setup-ver-x.xx.exe” file in the Win-GRAF installation CD(or download
the latest version of the Win-GRAF Workbench on the website: http://www.icpdas.com/root/
product/solutions/softplc_based_on_pac/win-graf/download/win-graf-driver.html) to begin the
process.

2. Click “Next” to continue and then select “I accept the agreement”, then click “Next” to continue.
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3. Recommend to use the default installation path (i.e., “C:\Win-GRAF”) and then click “Next” to
continue.

4. Click “Next” to add a “Win-GRAF” folder shortcut in the “Start” menu, and then select “Create a
desktop icon” to add a desktop shortcut, then click “Next” to continue.
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5. Click “Install” to begin installing the Win-GRAF Workbench.

6. Before the end of the installation, you will see a pop up window and it displays:
a. The legal Win-GRAF Workbench is delivered with a legal Win-GRAF Dongle distributed by ICP DAS.
Please always plug the Win-GRAF Dongle in your PC while running it.
b. To run the Win-GRAF, require Microsoft “.Net FrameWork 3.5” installed in your PC.
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7. By now, you have completed the Win-GRAF installation, then click “Finish” to exit this window.
(Select “Launch Win-GRAF” to auto-run the Win-GRAF after completing the setup. If there is no
Win-GRAF Dongle in your PC, the Win-GRAF Workbench will run in Demo mode.)

1.2 Run the Win-GRAF Workbench
Before running the Win-GRAF Workbench, make sure the Win-GRAF Dongle is plugged into your PC.
Without using a Win-GRAF Dongle, the Win-GRAF Workbench will run in Demo Mode. Open the
Windows Start menu, click on “Win-GRAF” folder and “Win-GRAF” to open this software.

Description of the “Win-GRAF” folder:
Libraries: For users to create their own function or modify an exist function.
Handbook: The manual details the software interface, programming environment, programming
languages, and so on, provided by COPALP.
(Or click the [Help] > [Topics] from the Win-GRAF menu bar)
History:
The modification history and features added of the Win-GRAF Workbench.
Manual: The Win-GRAF manual provided by ICP DAS.
(Or click the [Help] > [Tutorials] from the Win-GRAF menu bar,
the manual is located in the path “C:\Win-GRAF\Tutorials”)
ReadMe: The notice for the Win-GRAF Workbench.
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1.2.1 Win-GRAF Operating Mode
The Win-GRAF Workbench provides two operating modes:
“Demo Mode”: Without using a Win-GRAF Dongle. The compiled Win-GRAF project can run for 15
minutes in the PAC. Once the time limit has expired, users must Stop/Start this
project again and it only supports up to 40 I/O tags.
“Large Mode”: Using a Win-GRAF Dongle. The project can run in the PAC without the time limit.
Demo Mode - Without using a Win-GRAF Dongle.
The start screen will show as below after running the Win-GRAF Workbench.

No Win-GRAF Dongle found. Demo mode!

It describes the limitations in
demo mode, you can also
click the main menu [Help] >
[About] to see this content.

Note: If you install the Win-GRAF Dongle in the Demo Mode, you must close Win-GRAF Workbench and
then start it again to make it become Large Mode.
Large Mode - Using a Win-GRAF Dongle.
The start screen will show as below after running the Win-GRAF Workbench.
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1.2.2 Win-GRAF Operating Environment
Run the Win-GRAF and then the main screen will show as below:

Menu bar / Tool bar

B

Program Area
A

Workspace

C

Message Area

A. The Workspace:

It allows users to create project lists, and add/open the Win-GRAF program as
well as the related settings. Moreover, the new project can be created by using a
project template.
B. The Program Area: It used to show/edit the program and can be divided into more function area.
(Refer Section 2.2.1)
C. The Message Area: It used to show compiler messages and provides more diagnostic tools.

Tips:
1. To resize a window, click and drag the side or corner of the window to change its size.
2. Press the “F1” key to open the user manual (i.e., HTML Help).
Hind or Show the window
If you carelessly closed the Variables pane or the Message Area during the programming, you can click
the menu bar "View" and select the following options to open this window again.

Output:
It means the Message Area.
Infos Tab1: It means the Program Area – Variables pane (refer the Section 2.2.1).
Infos Tab2: It means the Program Area - Function Blocks pane (refer the Section 2.2.1).
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1.2.3

Win-GRAF Library Manager

Win-GRAF Workbench provides a Library Manager that can be used to look up all descriptions for
Functions, Function Blocks and I/O Boards. (The user can refer section 11.1 in the Win-GRAF User
Manual to upgrade the Win-GRAF Lib.)
1. To begin this, click the Start button and click "All Programs" > "Win-GRAF" > "Libraries" > “OEM”.

2. In the “Library Manager” window, click the menu bar “File” > “Open Library” and select “ICP DAS –
XP-WP-VP” then click “OK”.
3. Select any title in the “Function and FBs” tab and click the “Description” to view the usage of this
Function or Function Block; Select any title in the “I/Os” tab and click the “Description” to view the
usage of this I/O Boards.

Win-GRAF Getting Started, Ver. 1. 01, Oct. 2014 by ICP DAS

1-9

1.3 Setting the Win-GRAF PAC’s IP Address
For connecting with the PAC, the Win-GRAF Workbench need to know the PAC IP. The following will
show you how to set up the PAC IP. Using the XPAC (XP-8xx8-CE6, XP-9xx8-CE6) and the WinPAC
(WP-8xx8, WP-5xx8) as the example:
Hardware Wiring Diagram

PAC Side
Using the USB mouse that connected to the PAC, and click “Start” > “Settings” > “Network and Dial-up
Connections” on the left-side of the monitor, then double-click the “LAN1” (or LAN2), then fill in a
proper IP address.

2

3

1

Click to use the keyboard
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Open the “WinPAC_Utility.exe” (or “XPAC_Utility.exe”) on the desktop (or \System Disk\tools\).Then,
click “File” > “Save and Reboot” to reboot the PAC.
Notice:
For connecting properly, the PC/Win-GRAF IP and the PAC IP must in the same network segment.
For example, set the PC’s IP to “192.168.1.20” (Mask: 255.255.255.0).
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Chapter 2

A Simple Win-GRAF Program

2.1 Creating a New Win-GRAF Project
The following sections will introduce you to a simple template project that used to get/set (read/write)
the Win-GRAF PAC‘s system time. Follow the steps below to complete this demo program.

2.1.1 Creating a template project (Demo01)
1. Run the Win-GRAF Workbench (refer Section 1.2), and click "File / Add New Project..." from the
menu bar.

2. Click “From template” to create a project from a template, enter a project name (e.g., "Demo01") in
the Name field and add a simple note in the Comment field, then click "Next". By default, it will
show a "ICPDAS_template" option provided by Win-GRAF Workbench, just click "Next" to continue.

Recommend to use the default folder.
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3. Now, you have created the “Demo01” template project.

Note: In the demo01, we use a “From template” way to create this project. If you select "Project" in the
step2, click the "Release" in the “Compiling options" setting. The others setting can be done in
the following sections, just click "Next" and then "OK" button to end the settings.

“PAC IP:502”,
See Section 2.3.5
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2.1.2 Important project settings
There are two important settings must be done after creating the project.
1. In the "Workspace", mouse right-click the project name (e.g., "Demo01") and then uncheck the
"Alphanumeric Sorting" option (the last one). If unchecked, means the programs are in execution
order ; If checked, means the programs are in alphanumeric order (e.g., FBD1, LD1, ST1).

Right-click

Unchecked,
In execution order

Checked,
In alphanumeric order

Change the execution order of programs:
Note: If you want to change the execution order of programs, mouse right-click the project name
(e.g., "Demo01") and click "Cycle" (as the screenshot above) to open the settings window,
then click the "Move Up" or "Move Down" button to change the order.

2. If using the "Project" way to create a new project (in this example, we use the “From template” way,
refer Section 2.1.1 - Step 2), click the"Project" > "Settings..." from the menu bar to open the
"Project settings" window. Click the "General" option and set the "Complex variables in a separate
segment" to "Yes" to allow the using of complex data structures, such as arrays. Finally, click "OK" to
exit the window. (Note: The "Code Generation" must be set to "Release".)
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(Note: The "Code Generation" must be set to "Release".)
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2.2 Introduction of the Project
2.2.1 Demo01 - LD Program
This program is used to read/write the Win-GRAF PAC‘s system time. In the Workspace, double-click the
LD program name (i.e., “PAC_Time") to open all relevant windows. As the screenshot below, the
Program Area has three main parts:

Program Area

B. Variables
Area

Note:
, means the
program is locked and
cannot be deleted.

A. Program Editor
Area (LD)

C. Function
Blocks Area

Tips: Mouse click the Program Editor Area, and press the "+“ or “-” key to zoom in or zoom out the
content.

(E.g., press "-” key twice to
zoom out the content.)

A. Program Editor Area (LD):
This area allows to edit or display this LD program, you can click the object button (on the left of
Program Area) to add a program, and then drag-and-drop variables (in the Variables Area) onto the
function block one-by-one.
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R1: Get current time of the PAC

R2: Set “Set_new_time” to “True” to set the new time

R3: Reset it to “False”
B. Variables Area:
This area shows the function blocks and variables that used in this program. Mouse double-click the
“Name” or “Type” item to modify its name or data type, then click “Enter” to complete the setting.
(Refer Section 2.3.1 for the details about variable declaration.)
Note: For the function block can work correctly, the
“Inst_xxx..” FB instance variable will be automatically
added when using one function block. For the safety
reasons, this FB instance variable will not be automatically
deleted even if the function block has been removed in the
editor area. So, users can right-click the unwanted variable
and select “Clear” to manually remove it.

FB instance variable
variable

C. Function Blocks Area:
In the “Blocks” tab, it provides many types of the function block for users to drag and drop them to
the editor area.

Tips:
After selecting the function
block, press “F1” key to open
the HTML Help.
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2.2.2 Demo01 - Variables
In the workspace, mouse double-click the “Variables” item to open the Variables window. The following
screenshot shows all the needed and defined variables in this “Demo01” project.

Click it to sort by name.

Tips: In the Variables window, users can click any title field (e.g., “Name”) for sorting.
If you want to go back to the original sort order, mouse right-click anywhere and select the
“Cancel Sorting” option.

Field description: (Press the “F1” key to look up the details)
Mouse double-click any field item to set or modify the data.
Name:

A valid variable name starts with a letter (e.g., "A to Z" or "a to z") followed by any
number of letters, numbers (e.g., "0 to 9"), or an underscore (i.e., “_”).
Type:
Data type. (Refer Appendix A for the value range)
Dim.:
To specify the range of an array.
(E.g., enter “10”, means the use of the Counter [0] to [9]).
Attrib.:
Double-click this field item to set it to “Read Olny” that means users can only read this
variable but cannot modify it.
Syb.:
If checked, the variable name will also be downloaded into the PAC.
Init value:
To set the initial value of the variable.
User Group: All the variables can be divided into some groups (e.g., “Group1”, “Group2”) and it is
convenient for users to look up or search these variables.
Tag:
To enter a nickname for the variable.
Description: To enter a simple note for the variable.
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2.3 Give it a Try
As mentioned before, we have described the LD program (Section 2.2.1) and variables (Section 2.2.2) in
the "Demo01” project. The following sections will show you how to declare variables and add an LD
program with the blinking function in this project.
Note: All the Win-GRAF PAC does not support the “ULINT” and “LWORD” data type.

2.3.1 Declaring the Win-GRAF Project Variables
First, we will declare two boolean variables (i.e., "LED1" and "LED2") that used in the program.
1. In the “Variables” window, mouse right-click any item in the “Name” field and select “Add Variable”
(or press the "Ins" key or click the

tool button) to add a variable.

2. Double-click the new “NewVar” item and change its name to “LED1”, then click “Enter” to finish the
setting. In this case, the data type is "BOOL".

Note: The settings will be done only after clicking the “Enter” key.
3. Follow the previous steps to add the “LED2” boolean variable.

Tips: To set up multiple ordinal variables, enter the name “LED” (as the step2) and then press “Ctrl+C”
and “Ctrl+V” twice to create “LED1” and “LED2” (auto sequential numbering), finally, delete the
first variable (i.e., “LED”).
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Tip #2:
1. If you need to add multiple variables (e.g., “Boo_01 to Boo_16”), simply right-click the “Global
variables” and select the “Add Multi Variables”.

Mouse right-click

2. Follow the settings like the figure below (Name: “Bool_%%”; Type: “BOOL”; From: 1; To: 16) to
create Boolean variables (i.e., “Bool_01” to “Boo_16”) and then click “Create all” button to complete
the settings.

Win-GRAF Getting Started, Ver. 1. 01, Oct. 2014 by ICP DAS

2-9

2.3.2 Declaring the I/O Variables
In this example, the I-8055W module that used to show the blinking feature must be plugged in the
PAC‘s slot1. So, we need to add an I/O link to correspond to the real I/O module.
1. Click the "Open I/Os" tool button to add an I/O link.

2. Mouse double-click on "Slot 1” and then double-click the "i_8055" to select this I/O board.

3. Click the “Close” button to exit the “I/O Boards” window.
Note: Click the “Virtual/Real” button to change to the Virtual l/O (for testing) or the Real I/O.
(The Real I/O is used in this example).

Virtual I/O: (It shows in blue)
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After linking the “i_8055” I/O board, it will automatically add 8 input & output variables in the
“Variables” window.

%IX1.0 – i_8055_DI

%QX1.1 – i_8055_DO

“I” means “Input”
“X” means “Boolean”
“1” means “Slot 1”

“Q” means “Output”
“X” means “Boolean”
“1” means “Slot 1”

%ID or %QD
“D” means “Integer/Real”
There are three output variables are used in this example, and you can modify the name for easy use.
Mouse double-click the item and fill in a name, then press “Enter” key to finish the setting.
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2.3.3 Creating an LD Program
In the “Demo01” project, we want to create a “LD1” program to show the blinking. To begin, follow
these steps:
1. In the workspace, mouse right-click the “Programs” folder and select “Insert New Program…”.

2. Fill in a program name in the “Name” field and enter a simple note in the “Description” field, and
then select the “LD – Ladder Diagram” as the programming language and click the “OK” button.

3. Double-click the “LD1” program to open the editor window.
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4. Click the “Insert FB..” button on the left of the “LD1” window to add a function block.

Tips:
You can also drag and drop
the “BLINK” function block
into the “LD1” window.

5. Double-click this function block and select the “BLINK”, then
click the “OK” button.

Tips:
You can press the “BL” key
to quickly find out the name.

Tips: (Refer Section 2.2.1 – B)
Click the upper area, to change a FB instance variable.
Click the lower area, to change a function block.
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Important Notice:
When programming, users may copy & paste an existing function block to create a new one. But,
this way will cause a function exception due to the same function instances. Therefore, users must
create a new name for the function instance.
1. Mouse double-click the function block and enter a new name (e.g., “Inst_BLINK1”), then click the
button to complete the setting.

1

2. In the “Inst_BLINK1” window, click “Yes” to create this function instance.

2

Tips:
You can also use the same way to
double-click on the right-side of the
“Coil” to create or assign a variable.
(See Step7)

3. Now, there is an “Inst_BLINK1” function instance added in the Variables Area.

3
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6. Click the “Coil” on the right of the “BLINK” function block, and continuously click the “Insert Coil”
button to add four “Coil”.

1

Tips: press the “+” key to zoom in the content.

2

7. Mouse double-click the first “Coil” and double-click “LED1” to assign it. Follow the same way to
assign the “LED2” variable to the second “Coil”.

8. As the screenshot below, mouse drag-and-drop the “Output1”, “Output2” and “Output3” variables
to the 3th, 4th and 5th “Coil”.
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9. Mouse double-click on the left of the “CYCLE” and enter “T#2S” (to blink every two seconds), and
then click

to finish the setting.

10. Finally, click the “Save” button to save the “LD1” program.

Note: “

” means this program is opened (locked, cannot be deleted). Click the “X” in upper-right

corner of window to close this program (un-locked, “

”).
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If you want to add a program to the first line after completing the programming, follow these steps:
1. Click the upper-left corner of the Program Editor Area, and you will see the selectable items on the
Object bar. Select an object (4 to 7, as the screenshot below) to add a program to the first line.
Note: You can also select an object (1 to 3) to add it on the left of the current program.

Add a object on the left of the current program:
1. Insert contact before (shift + F4)
2. Insert horizontal line (shift + space)
3. Insert FB before (shift + F8)

Add a object on the left of the program:
4. Insert jump (shift + F9)
5. Insert Coil (F9)
6. Insert new rung
7. Insert commecnt line

2. In this case, click “Insert new rung” to add it to the first line.
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2.3.4 Compiling the Program
In the previous section, we have added and saved the LD program. For the Win-GRAF project can
function properly in the PAC, we need to compile the programs. To begin, follow these steps:
1. On the menu bar, click “Project > Build All Projects” to compile all programs.

2. If a “No error detected” message is appear that means the project was successfully compiled.
Note: If you modify and save the program after compiling it, click the “Clean All Projects” to clean
the previous results and then do the step1 again.

Check to see if there is any
error message here.

If the Win-GRAF is running in Demo
Mode, this message means the
Win-GRAF project can run for up to
15 minutes in the PAC.
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2.3.5 Download the Program to PAC
Before downloading the program, you need to set up the communication parameters. (By now, it only
supports the Ethernet TCP/IP).
1. Mouse right-click the project name (i.e., "Demo01") and select “Communication Parameters…” to
open the settings window.

2. Enter the “PAC IP:502” (e.g., “192.168.255.1:502”) to add an IP address and then click “OK”.
It can also click the
button to add/modify the IP address.
(Note: the default PAC IP is “192.168.255.1” and the fixed port number of Win-GRAF PAC is “502”)

Tips: All the configured IP will be listed here. You
can select the unwanted IP and press “Del” key to
delete it (e.g., “192.168.78.8: 502”).

3. Before establishing a connection, make sure the PAC and the network are working properly.
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4. Click the menu bar “Project” and select “On Line”, or click the
connection.

tool button to establish a

5. As the screenshot, if it shows “App: TEST”, different to the current project name (i.e., “Demo01”),
that means there is a project (name: “TEST”) running in the PAC. Click “Stop application” tool button
to stop the “TEST” project.

6. Click the “Download” tool button to download the “Demo01” project.

7. If it shows “RUN” that means the "Demo01" project is successfully running in the PAC.

It shows the current
time of the PAC.
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Note: If there is any error message show up during the download process, refer Appendix B to get the
solution.
Cycle time
When on-line with the PAC, move your mouse over the “RUN” position on the toolbar to view the
current cycle time of the program in the PAC. You can also view the cycle time in the bottom-right
corner of the message area.

When doing the “On Line” (
) operation, it will automatically switch to the “Runtime” tab and you
can see if there is any error message for the downloaded program. (E.g., in this example, we need to
plug the I-8055W module in the Slot1 of the PAC, and the message “Board error in the slot No. 1 !”
means there is no I/O module in the Slot1 or an I/O exception.)
Shutting down the PAC, and plug one I-8055W module in the PAC’s Slot1 then reboots. Then, click
“On Line” (

) button to connect to the PAC.
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2.3.6 Testing the Program
In the previous section, you have successfully downloaded the “Demo01” project and the following will
describe how to test the program.
The “PAC_Time” Program:
1. Mouse double-click the variable name (e.g., “new_Year”) in the “TIME_SET” function block (or the
Variables Area) one-by-one to change the PAC’s system time (e.g., to change it as January 1, 2015
12:30:35).

2. Set the “Set_new_time” variable to “TRUE” to write the new system time.
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3. Then, the new system time will show on the “TIME_GET” function block (or the Variables Area),
and the “Set_new_time” variable will be reset to “FALSE” automatically.

The new system time.

The “LD1” program:
4. When the “Demo01” project is running, you can check to see if the DO0, DO1 and DO2 tags of the
I-8055W I/O module that plugged in the slot1 of the PAC is blinking every two seconds (like the
value "T#2S” we set before). You can also assign a “TIME” variable on the left side of the “CYCLE”
for easier to change the time setting. Refer Section 2.3.1 for the setting way.
5. If the “%QX1.1.3” variable is set to “TURE” in the Variable Area, the LED4 (i.e., “DO3”, at the top of
the I-8055W I/O module) will light up.

顯示 PAC 系統時間。

6. Click the
tool button again to cancel the PAC connection.
Note: Do NOT click the “Stop Application” button; it will stop the running project in the PAC.
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Chapter 3 Modbus Slave: Allowing the SCADA/HMI Software

to Access Win-GRAF Variables
In Chapter2, we have described how to get/set the PAC system time (i.e., the “PAC_Time” program) and
create a blinking function (i.e., the “LD1” program) in the “Demo01” project. The following sections
describe how to allow the SCADA/HMI software (e.g., “InduSoft”) to access Win-GRAF variables that
defined in the "Demo01" project. The Win-GRAF Workbench provides two ways to open the PAC data,
one way is to enable the Win-GRAF PAC as a Modbus TCP Slave and the second way is to enable the
Win-GRAF PAC as a Modbus RTU Slave (you must first complete all the Modbus Slave settings in Section
3.1, and then refer Section 3.2). To begin, follow these steps:

3.1 To Enable the Win-GRAF PAC as a Modbus TCP Slave
1. Click the “Open Fieldbus Configuration” tool button to open the “I/O Drivers” window.

2. Click the “Insert Configuration” button on the left side of the “I/O Drivers” window and then select
the “MOSBUS Slave” and click “OK” to enable a Modbus TCP Slave.
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3. Click the “Insert Master/Port” button on the left side to set the “Slave number” (In this case, the
value is “1”), and click the “OK” button.

4. Click the “Insert Slave/Data Block” button on the left side to open the “MODBUS Slave Request”
window.

Tips:
1. Press the “F1” key to open the Help on this subject.
2. If you add two or more “Server - …” settings, type a
“Server ID” for easier use (a string, e.g., `SVR1’)

5. Enter a simple note in the “Description”
field and then click the "Input Registers”
option.
For Modbus Master to Read data:
Options
Data Types
Input Bits
BOOL
BYTE, INT, DINT,
Input Registers
REAL, etc.
For Modbus Master to Write data:
Options
Data Types
Coil Bits
BOOL
Holding
BYTE, INT, DINT,
Registers
REAL, etc.
(Refer Appendix A to see more data type)

Enter a simple note.

Recommend to set
“Base address” to “1”
and set the value of
“Nb items” is greater
than “200”.
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6. As the screenshot above, it’s recommended to set the “Base address” to “1” and the “Nb items”
refers to how much variable data can be provided by one “Data block”. If the data address requested
from the Modbus Master (e.g., the SCADA software) is greater than this value (in this example, the
value is “2000”), the Modbus Slave (i.e., Win-GRAF PAC) will not respond.
7. Mouse drags all the needed variables (e.g., “PAC_xxx”, data type: “DINT”) one-by-one from the
Variables area and then drop it to the “Symbol” field.

8. Mouse double-click the “Offset” field and fill in a value, then press “Enter” key to finish the setting.
Note: (1) The “Offset” value starts at “0” and the Modbus address of variable is equal to this value
plus 1 (Base address).
(2) If using a 32-bits (or more than 32-bits) data type (e.g., “DINT”, refer Appendix A), it requires
two Modbus addresses, as the table below, the “Offset” values are 0, 2, 4, 6, and so on.

Enter

Tips:
Mouse click the “Offset” field and press the keyboard “Ctrl+A” to select all items, and then click the
“Iterate Property” button at the left-side to open the settings window.

Ctrl+A
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Keep the “Name” setting, enter “0” into “From” field and enter “2” into “By” field, then click “OK”.
(If setting the “Name” to “%%”, it will show “00, 22,
44, 66, 88, 1010, 1212” in this example. To modify it
depends on the required settings and then check
the value in the “Results” area.)

9. Click “Storage” to select entire columns and then press “Enter” key to display a drop-down menu.
Then, select “DWORD (Low – High)” and press “Enter” key to complete the setting. (If using a 16-bits
or below, it’s no need to set the “Storage” item.)

To expand this “Data Block” and you can see the Modbus addresses of all variables. It equals to the
“Offset” value plus 1 (Base address).
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10. Then, we need to add the second “Data Block” for the Modbus Master to read the Boolean data.
This configure way is similar to the step 4 to 8:
(1) Click the “Server - …” item and click the “Insert Slave/Data Block” button at the left side to open
the settings window.
(2) In the “MODBUS Slave Request” window, enter a simple note and select the “Input Bits” option,
then set “Base address” to “1” and set “Nb items” to “2000”.

Enter a simple note
For the Modbus Master to Read data:
Option
Data Type
Input Bits
BOOL
BYTE, INT, DWORD,
Input Registers
REAL, LINT, etc.
(Refer Appendix A to see more data type)

(3) Mouse drags the Boolean variables (i.e., “LED1”, “LED2”; data type: BOOL) one-by-one and drop
them to the “Symbol” area, and then set the “Offset” to “0” and to “1”.

You have completed the settings for the Modbus Slave. Finally, follow the way below to re-compile
the program and download it to the Win-GRAF PAC.

Win-GRAF Getting Started, Ver. 1. 01, Oct. 2014 by ICP DAS

3-5

11. Click the menu bar “Project” > “Build All Projects” to compile this program again (refer Section 2.3.4).
If a message informs you “No error detected” that means this process is successful.

This version information can be ignored.

12. Mouse right-click the project name (i.e., “Demo01”) and select the “Communication Parameters…”
to set the PAC IP (e.g., “192.168.71.19:502”) and then click the menu bar “Project” > “On Line” (or
) to establish a connection and download this project to the Win-GRAF PAC. (Refer Section
2.3.5).

SCADA / HMI

Win-GRAF PAC
IP: 192.168.71.19
Port: 502

InduSoft
Slave number = 1
WP-5xx8
Modbus TCP Master

WP-8xx8

Modbus TCP Slave
(Refer to P1 to view all PAC models)

After completing all the steps, the HMI/SCADA software can access to all the Win-GRAF variables listed
above via Modbus TCP protocol.
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3.2 To Enable the Win-GRAF PAC as a Modbus RTU Slave
Before doing this, you must complete all the content that described in Section 3.1 to open the Modbus
Slave data. The way to enable the Win-GRAF PAC as the Modbus RTU Slave is to add the “MBSLAVERTU”
or the “MBSLAVERTUEX” function block in the program. To begin, follow these steps:
Add the “MBSLAVERTU” function block
1. In the “LD1” window, mouse click the place where you want to add this function block and then click
the “Insert FB..” button on the left side of the window.

3

2

1

2. Double-click on this function block and select the name “MBSLAVERTU”, then click “OK”.

Tips:
Press “MBSL” key to quickly
find out the function name.
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3. In the “MBSLAVERTU” function block, mouse double-click the left side of the “PORT” and enter a
string 'COM2:9600,N,8,1' (it means using the Win-GRAF PAC’s COM2 to communication with the
Modbus Master) and then click

to complete the settings.

Tips:
Press the “F1” key on this
function block to show up
the related Help.

4. Double-click the left side of the “SLV” and then enter “1” (the value set in the Section 3.1 - Step 3),
then click

to finish the setting.

Now, you have completed the setting of the “MBSLAVERTU” function block, then re-compile the
program and download it to the Win-GRAF PAC. (Refer Section 2.3.4, Section 2.3.5)
Note: Users can enable multiple Modbus RTU Slave in one PAC (recommend not over 16 Ports), the
way is to add multiple “MBSLAVERTU” function blocks and set the different “Port” value.
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SCADA / HMI

Win-GRAF PAC
COM2: RS-232
9600,N,8,1

InduSoft
Slave number = 1
Modbus RTU Master

WP-5xx8

WP-8xx8

Modbus RTU Slave
(Refer to P1 to view all PAC models)

Add the “MBSLAVERTUEX” function block
If you have added multiple “Server - …” settings (recommend to set one) in the “I/O Drivers” window,
the “MBSLAVERTUEX” function block must be used.

1. Follow the step1 to 4 described above to add the “MBSLAVERTUEX” function block. If you want to
change the usage for existing function block, mouse double-click the “MBSLAVERTU” and change it
to the“MBSLAVERTUEX”, and then click the “OK” button.
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2. The “MBSLAVERTUEX” has a “SrvID” setting. Mouse double-click the left side of the “SrvID” and
enter a required “Server ID” (using a string format, e.g., ‘Svr1’).
Note:
If using the “MBSLAVERTU” function block, the first Mobus Slave settings will be used.
If using the “MBSLAVERTUEX” function block, it depends on the “Server ID” in the Modbus Slave
settings.

Tips:
Press the “F1” on this
function block to show
up the related Help.

You have finished the settings for the “MBSLAVERTUEX” function block and then re-compile the
program and download it to the Win-GRAF PAC. (Refer Section 2.3.4, Section 2.3.5)
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Appendix A Data Types and Ranges
Users can specify the data type of variables in the Variables Area (refer Section 2.2.1) or in the Variables
window (refer Section 2.2.2).

Below are the available basic data types and ranges:
Data types

Size in Bits

Range of Values

BOOL (*)

---

TRUE，FALSE

SINT

8 bits (Small int, signed)

-128 ~ +127

8 bits (Unsigned small int)

0 ~ +255

16 bits (Int, signed)

-32768 ~ +32767

16 bits (Unsigned int)

0 ~ +65535

32 bits (Double int, signed)

-2147483648 ~ +2147483647

32 bits (Unsigned double int)

0 ~ +4294967295

64 bits (Large int, signed)

-263 ~ +(263-1)

64 bits (Unsigned large int)

0 ~ +(264-1)

REAL (*)

32 bits (Floating point)

±3.4×10-38 ~ ±3.4×1038

LREAL

64 bits (Floating point)

±1.7×10-308 ~ ±1.7×10308

STRING (*)

A max. of 255 characters

---

USINT
BYTE
INT
UINT
WORD
DINT (*)
UDINT
DWORD
LINT
ULINT
LWORD

TIME (*)
32 bits
(*): The common used data type.

T#0ms ~ T#23h59m59s999ms
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Appendix B Troubleshooting while On-Line the PAC
If the error message is showing up (as the screenshot below) after connecting to the Win-GRAF PAC,
refer the following content to solve the problem.
 The “Bad version!” error message:
It means that the compiled version between the PC and the PAC is different. The most common
reason is that users have modified and re-compiled the program.
To solve the problem
1. Click the “Stop application” button to stop the running program.

2. Click the “Download” button to download the program again.

3. The “RUN” message means that the program is working properly.
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 The “Communication error” error message:
A communications failure has occurred between the PC and the PAC.

To solve the problem
1. Make sure your Win-GRAF PAC is started, and the network communication between the PC and the
PAC is functioning properly.
2. Make sure the IP setting of the Win-GRAF project is the same as the PAC IP (Refer Section 2.3.5, in
this example, the IP address is “192.168.255.1:502”).
3. Make sure the network communication of your PC is working.
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